Customers using Jira Service Management are currently experiencing issues when attempting to access the Organizations tab. They encounter an error message. This affects the usability of this feature within the product.
Current Status
We've rolled out the fix and are monitoring the impact. We are seeing a reduction in errors.
Next Steps
We'll provide an update once we've verified the fix.
Posted Sep 19, 2025 - 13:28 UTC
Identified
Impact
Customers using Jira Service Management are currently experiencing issues when attempting to access the Organizations tab. They encounter an error message. This affects the usability of this feature within the product.
Current Status
Our teams have successfully reproduced the issue and have identified the fix.
Next Steps We will start rolling out the fix soon.
Posted Sep 19, 2025 - 12:45 UTC
Investigating
We are investigating reports of intermittent errors on Jira Service Management Cloud customers' Organizations page. Once we identify the root cause, we will provide more details.
Posted Sep 19, 2025 - 07:58 UTC
This incident affects: Jira Service Management Web.